
INFORMATION AND COMMUNICATION TECHNOLOGY

STANDARD 10

First Terminal Evaluation

SECTION 1 
Choose the correct answer.

1.How does the increase in dpi affect the beauty and clarity of an image   ? 

a) Increases
b) Decreases
c) Blurs
d) Doesn't affect the picture

Answer : a) Increases

2.One the following four vector soft-wares is not an open source software. Select that software.
a) Open Office Draw
b) Dia
c) Adobe Illustrator
d) Ink scape

Answer :c) Adobe Illustrator

3.What is the use of this tool in Inkscape? 

        
           a) To change of the colour of the object   
           b) To change the colour of the gradient
           c) To select the objects
           d) To group the objects
  
Answer : c)To select the objects

4.Which of the following techniques will help Anoop to give a  colour of his choice to the picture 
of amoeba drawn in  Inkscape?

a) Edit > Duplicate         –
 b)Edit > Clone–

c)Object > Fill and Stroke  –
 d)Object  > Object Properties–

 Answer : c)  Object > Fill and Stroke  –

5.David likes to save his picture of Amoeba drawn in Inkscape as a raster one. Choose the  activity 
for the purpose from the given list.



           a)file.....>Save as Bitmap
b)file.....>Export Bitmap
c)file......>Insert Bitmap
d)Edit.....>Bitmap

Answer :  b) file.....>Export Bitmap

6.In Inkscape it is possible to take copies of an image. Choose the activity for the purpose from the 
list given below ?

a) Path  difference→
b) Edit path by node
c)Path  Union→
d) Edit   duplicate→

Answer: d) Edit   duplicate→

7.The increase in size of an image drawn in Inkscape never affects the quality and beauty of the 
picture. Why?

a) The Picture is divided  as a group of  squires
b) The Picture is saved as mathematical symbols.
c) The Picture is saved as a group of pixels
d) The  squires in the image are coloured.

Answer : b)The Picture is saved as mathematical symbols.

8.How does the change in stroke  colour affect the following object?

          a) The fill colour  changes.
b) The colour of the outer line  changes 
c) The external colour  changes
 d)The colour of the software window  changes.

Answer : b) The colour of the outer line  changes

9.A picture drawn in inkscape is given the name 'rose.svg'. Expand the extension 'svg'
a) Scalable Velocity Graphics 
b) Scalar Volume Graphics
c) Scalable Vector Graphics
d) Sector Vector Graphics

 Answer : c)  Scalable Vector Graphics



10.Amal wants to draw a flower. He has drawn a petal of the flower. Suggest him a method to 
make copies of the petal so that he can complete his picture.

a) Object    Group→
b)  Path   Exclusion→
c) Edit  Duplicate     →
d) Text   Put on path                                                       →

 Answer : c) Edit  Duplicate→

11.Sunitha draws a triangle and a circle in Inkscape as shown in picture A. How does she change 
the image as shown in picture B?

         

a)  Object  Group→
b)  Object    Raise→
c)   Path    Difference→
d)  Path    union→

Answer: d) Path    union→

12.How can you save an image drawn in Inkscape in png format?

a) File    New →
b) File    Import  →
c) File    Export bitmap  →
d) File    Open  →

Answer c) File    Export bitmap→

13.How do you create a single image out of three pictures  drawn in Inkscape in the same canvas?

a) Object group–
b) Edit - clone
c) Object - Fill and Stroke 
d) Edit  copy–

Answer : a)  Object group–
7)

14.In order to create an arch Anu draws a circle in Inkscape and converts it into an arch by using a 
particular a tool. Name the tool.

 a) Draw Bezier curves and straight lines.
b) Create circle



           c) Zoom 
 d) Edit paths by nodes

Answer : d) Edit paths by nodes

15.The following circles are created in Inkscape. Name the type of gradient that changed the colour 

of  the second one?

           a) Linear gradient

           b) Radial gradient 

c) Pattern gradient

d) Fill gradient

Answer : b) Radial gradient

16.Conditional statement is a method in spreadsheet  to categorize data. Identify the Function  for 

it.

a) LOOKUP
b) COUNT
c) RANGE
d) IF

Ans: d) IF

17.You may be familiar with the given icon.  What does it stand for?

           a) Mail Merge Wizard
b) Function Wizard
c) Data Source
d) Data Forms

Ans: b) Function Wizard



18. The entire data of students in a school is  included in a database, but the same admission 

number is repeated against the names of two students. What is the method in Open Office.org 

Database to eliminate this mistake?

           a) Field Name
b) Table 
c) Primary Key
d) Forms

Ans:  c) Primary Key

19. Which technique in database uses for finding specific information ?

a) Table
b) Form
c) Queries
d) Report

Ans: c) Queries

20.The following lookup Chart is prepared to be saved with the name 'Exam' in  Define Range. 

Where will you gave the name 'Exam' in the LOOKUP function wizard to asses the grade ?

a) Search Criterion
b) Search Vector
c) Result Vector
d) Range Vector

Ans: b) Search Vector

21.Where does the data collect in a database?

a) Data Form
b) Report
c) Queries
d) Table

Ans: d) Table



22.Identify the features found in the window of Open Office Database?

a) Tables, Queries,Forms, Reports
b) Tables, Functions, Forms, Reports
c) Queries, Tables, Save, Functions
d) Tables, Queries, Functions, Save

Ans: a) Tables, Queries,Forms, Reports

23.  The complete  data of  students  in a particular  class  is  listed in  a table.  Which among the 

following techniques will help you to prepare name slips for the entire class? 

a) Data Form
b) Mail Merge
c) LOOKUP
d) Chart

Ans: b) Mail Merge

24.Rama  teacher  listed  the  different  scores  of  her  students  achieved  in  various  subjects   in 

Spreadsheet. She wanted to see the grade of each student. Which technique in Spreadsheet will 

help her for that?

a) LOOKUP
b) ROUND
c) COUNT IF
d) AVERAGE  

Ans: a)  LOOKUP

25.The class teacher prepared the mark list of the students in spreadsheet based on their scores in 

the first terminal examination. later ,the class leader was asked to prepare the grade list of the 

students based on the table. which function would he use to prepare the grade? 

             a) Sum
             b) average

  c) lookup
  d) index

ANS:  C) lookup



26.In which field (box) of lookup function wizard in spreadsheet  will you add the name  given at  

the time of defining range ?

                     a) Search  Criterion
                     b) Search Vector

c) Result Vector
                     d) Result Criterion
   Ans:  b) Search Vector 

Qn No 27 is not found .

28. Rema teacher prepared the admission register in Open Office database. Now she wants to link 
the register with the concerned table in Open Office database. Which among the following 
techniques will help her? 

a)  Tools    
b)  Queries    
c)  Forms      
d)  Reports

                                  
Ans: c) Forms 

29.Rasheed classifies the entire students of his class with the help of a table in Spreadsheet that 
comprises the total mark of every students. Which technique would he use to classify the 
data?
a)  IF       
b)  LOOKUP     
c)  COUNTIF      
d)  ROUND

Ans  :   b)  LOOKUP 
30.The Software applications that allow secured handling of databases are called DBMS. Expand 
DBMS.

a) Database Managing System.
b) Data Basic Management System.
c) Data basic Managing System.
d) Database Management System.

Ans: d) Database Management System.
31.An organised collection of various information specially saved for specific purposes can be 

termed as
a) Inkscape
b) IDLE
c) Gimp
d) Database

Ans : d) Database 



32.How does a Data Form in Spread Sheet  help you? 
A. To include data in the table.
B. To analyse data.
C. To send the data
D. To classify the data.

Ans: A. To include data in the table.
33.Which of the following soft-wares helps us to create Python Codes?
         a)wxGlade
         b)Sunclock
         c)Inkscape
         d)Geogebra
  
 Ans:wxGlade

34.Find out which of these is Add a TextCtrl tool in the software wxGlade.
     a)

     b)

     c)

     d)

Ans:   

35.
     a=1
     b=2
     print 'a'+'b'

What will be the output of the above given python program prepared by Shan? 

a) 12 b) 3

c) ab d) a+b

Ans : a)12

36.
 a=range(10,1,-2) 
      print a
    What will be the output of this python program?

a) -2  -4  -6  -8  -10 b) 10  8  6  4  2  0

c) 10  8  6  4  2 d) -10  -8  -6  -4  -2

Ans : c) 10  8  6  4  2



37.What would be the output of the following python program prepared by Raju?

p= MY INDIA“ ”
n=len(p)
print n

A)  7   
B)  8
C)  6
D)  10

Answer : B)  8

38.What is the command used to include the turtle graphics in a Python program?
a. insert  turtle

b. from turtle import*

c. show turtle()

d. turtle import*

Ans: from turtle import*

39.What is the use of the command e='7'  in python program?

 a. To assign the number 7 in the variable 'e'.

 b. To assign the number 7 as a letter in the variable 'e'.

 c. To assign 7 letters in the variable 'e'. 

 d. None of these.

Ans:  To assign the number 7 as a letter in the variable 'e'.

40.What is the function used to change the numbers given to the computer through text boxes as 

numeric data in python program?

a. Num

b. int

c. Value

d. string

Ans: int

41.Which one among the following is the command for running a set of commands included in a 

python program repeatedly?  

A) for



B) import

C) raw_input

D) print

Ans: A) for

42.Select python file  from the  files given below

A)calculator.svg

B)calculator.odt

C)calculator.png

D)calculator.py

Ans:D)calculator.py

43.What is the output of the following python program prepared by Syam?

a= WE ARE INDIANS” ”
print a[:6]

a) WE 
b) INDIANS
c)ARE INDIANS
d)WE ARE

Ans:  d. WE ARE

44.From the given below commands find out the correct one to assign 5 different values to a 

variable in a python program.

(a)for
(b) while
(c) i=range(5)
(d) range[5]

Ans (c) i=range(5)

45.Find the correct python command for assigning the numbers from 5 to 1 in decreasing order in 

the variable 'i'.

(a)  i = range (5,0,-1)



(b) i = range (5,0,1)

(c) i = range (5,1,-1)

(d) i = range (1,5,-1)
           

Ans (a) i = range (5,0,-1)

46.Select the command in python program with which the function range is used.

Options
a) for
b) while
c) if
d) print

Answer a) for

47.Sunil saved a function to find the sum of two numbers named sum.py in his folder. Which 

command can be used to import this function to another program. 

Options
a) import sum.py
b) import sum
c) print sum
d) print sum.py

Answer b) import sum

48. What will be the possible output if you press enter key after typing the command  range(4,2,-2) 

in a python shell. 

a.) [4,2,-2]
b.) [4]
c.) [4,2]
d.) [4,3,2]

Answer  : b.) [4]

49. a = k  “ ”

for i in range (1, 11): 
    print i * a 



How many rows you can see in the output of the  given python program 

a.) 11
b.) 12
c.) 1
d.) 10

Answer     : d.) 10

50.What command is to be given for getting back the answer for  the main program while running 

a function prepared in python language?

Options
a) print
b) return
c) import
d) input

Answer b) return

51.What is the output of the given python program 

a= WELCOME” ”
print a[:2]

a)WE
b) ME
c)LC
d) CO

 Answer :   a)  WE

52.The following is a function named 'rm'  prepared by Anup.

def rm(a,b)
 c=a-b
 return c
What is the purpose of this function?

a) To add two numbers.
b)  To find the difference of two numbers.
c) To define the variables a and b. 
d) To use the variables a and b in the program.

Answer :b)To find the difference of two numbers.                                        

53.Opening www.wikimapia.org Reghu  tries to mark the place where his school is situated . When 

does he get the window for entering the school details ? 

http://www.wikimapia.org/


a. When clicks Edit map

b. When clicks Map Type  

c. When clicks Save button

d. When clicks in Add place

Ans:-  c. When clicks Save button.

54.In which menu is the Buffer tool that makes possible to create a particular zone with respect to 

a Geographic information extending to a particular distance in QGIS software?

a. Layer
b. Vector
c. File
d. Edit

Ans:-   b. Vector

55.Which statement is true regarding QGIS Map?

a. There in only a single layer in QGIS map.
b. The first layer is raster and other are vector layers in QGIS map. 
c. QGIS map is prepared by marking the features of a locality in separate layers.
d. The first layer is vector and the others are raster layers in QGIS map. 

Ans:-    c .QGIS map is prepared by marking the features of a locality in separate layers.

56. Which tool can be used to check the accuracy in  measures in buffered layers in QGIS 
Software?

           a) Node Tool
b) Measure Line Tool
c) Move Tool
d) Map Tips

Ans:-b) Measure Line Tool

57.Venu is preparing a map of his school  in QGIS software. Name the tool used to mark the 
boundaries in selected polygon layer?

  a. Toggle editing 
  b. New Print Composer
  c. Zoom Mode
  d. Buffer(s)

Ans. Toggle editing 



58.Nadathara Panchayat is planning to digitalize their map. Name the software  
suitable for the purpose

a) Stellerium
b) Q GIS
c) GIMP
d) wxGlade

Answer:b) Q GIS

59.Name the suitable layer type for preparing a layer to mark roads of a place in the map using 
QGIS software?

a)polygon
b)line
c)point
d)circle

Answer:b) line

60.Name an open source  software most suitable in each and every important stages of local level 
planning.

a)Stellerium
b)Q GIS
c)GIMP
d)wxGlade

Answer:b)Q GIS

61.What is the process to go to the Buffer tool that makes possible to create a particular zone with 
respect to a Geographic information extending to a particular distance in QGIS software ?

A.  Vector - Geoprocessing Tools - Buffer(s)
B.  Raster - Geoprocessing Tools - Buffer(s)
C.  Mark - Geoprocessing Tools - Buffer(s)
D.  Vector  Geometry Tools - Buffer(s)–

 Ans: A. Vector - Geoprocessing Tools - Buffer(s)

62.What type of map is Wikimapia?
a. Wall map.
b. Satellite map
c. QGIS Map
d. Globe.

Answer :  b. Satellite map



63. Which process is to be done for getting all the data stored in a layer as tables in QGIS 
Software?

a) Layer     N→ ew     N→ ew Shapefile Layer 
b)  Layer    → (right click)    O→ pen attribute table 
c)  Vector    → Geoprocessing tools    → Buffer 
d)  Vector   → Geoprocessing tools    → Intersect

Answer :   b    Layer    → (right click)    O→ pen attribute table

Section 2.Select the two correct statements from the options  
below.

1.Saritha draws a circle in Inkscape. How does 'Fill and stroke' help her to modify the circle?
Options

a)To change the size of the circle.
b)To colour the circle.
c)To increase the width of Stroke.

   d)To change the background of the page.
Answer

b)To colour the circle.
c)To increase the width of Stroke.

2.A rectangle and ellipse are created as shown in picture A. What methods do you follow to 
change it as  picture B?
Options

a)Use 'edit path by node tool'.
b)Select the ellipse and rectangle together.

c)path     →   difference

d)path →union
Ans:

b)Select the ellipse and rectangle together.

           d)path →union
3.Two of the following tools are seen in inkscape. Identify the 
tools.
Options

a) smudge Tool 

b) Edit path by nodes

c) Create Circle Tool

d) Healing Tool 

 



Answer :  
b) Edit path by nodes 

         c) Create Circle Tool 

4.The following logo is created by Pradeep in Inkscape. Pick out the different steps to complete the 
work?

a)               Three rectangles are created and coloured with the help of Create Rectangle Tool

b)               Three rectangles are created and coloured with the help of  Transform Tool

c)        Type the text 'IT @ School' inside the boxes and modify it with Text Tool 

d) Type the text 'IT @ School' inside the boxes and modify it with  the help of Select Path 
by Node Tool

Ans:
a)          Three rectangles are created and coloured with the help of Create Rectangle Tool

c) Type the text 'IT @ School' inside the boxes and modify it with Text Tool 

5.Find out two different tools to draw a polygon in Inkscape.

a) Draw the Polygon With Create spirals Tool.

b) Draw the Polygon With Create stars and polygons

c) Draw the Polygon With Draw Bezier curves and straight lines Tool        

d) Draw the Polygon With Text Tool.

Ans:
b)Draw the Polygon With Create stars and polygons

c)Draw the Polygon With Draw Bezier curves and straight lines Tool

6.Select the two correct statements from the from the given list.

a) In Inkscape the tools and canvas are seen in the same window.



b) In Inkscape the tools and canvas are seen in various windows.
c) In GIMP the tools and canvas are seen in the same window.
d) In GIMP the tools and canvas are seen in various windows.                                     

Ans: 
a) In Ink scape the tools and canvas are seen in the same window.
d) In GIMP the tools and canvas are seen in various windows.  

7.How do you arrange the position of an object in Inkscape above or below an object in the same 
canvas. Find out two different ways from the list given below.

a)Page Up
b)Object → Lower
c)Page down Key
d)Object  Transform→

Answer:
 b)Object  Lower,   →
 c)Page down

8. Gopika has drawn a sphere in Inkscape. Identify the two activities  she might have gone through 
to complete the work?

a) Create a circle with create Circle Tool

b) Create a circle with Spiral Tool.

c) Give colour by using Edit Paths by Nodes Tool.

d) Double click in the circle after selecting Radial Gradient tool from Gradient Tool. 

Answer : a) Create a circle with create Circle Tool
d) Double click in the circle after selecting Radial Gradient tool from 

Gradient Tool.

9. Compare the techniques 'Duplicate' and 'Clone' in Inkscape, and select two correct statements 
from the list given below

a) Both the techniques are meant to copy objects.
b) The colour is faded in duplicate.
c) Could not make changes in duplicate.
d) The changes in the parent image will reflect on the clone.

Ans: a) Both the techniques are meant to copy objects.
b) The changes in the parent image will reflect on the clone.

10. Find out  two methods for Subhash to change the circle drawn in Inkscape to a semi-circle.



a) Draw the circle and use the tool  'Edit path by Nodes' to change.

b) Draw the circle and use 'Edit  Cut'.–

c) Draw the circle and use 'Object Flip vertical'.–

d) Draw the circle and arrange 'Start' and 'End' in the control bar. 

Ans:-
a) Draw the circle and use the tool  'Edit path by Nodes' to change.

d) Draw the circle and arrange 'Start' and 'End' values in the control bar.

11.Which among the following can be included in a LOOKUP Function wizard?

  (a) Search criterion 
  (b) Search vector  
  (c) Search data
  (d) Search file

Ans: (a) Search criterion 
(b) Search vector 

12.  Select two statements from the following list which may help you while creating a 
LOOKUP chart in Spreadsheet?

A. Avoid blank cells in Lookup  Chart.
B. The number of columns should be equal both in the Lookup  Chart and  table
C. The layout should be the same in Lookup  Chart and table.
D. A single cell should contain single value. 

Ans:    A. Avoid blank cells in Lookup  Chart.
D. A single cell should contain single value.

13. You want to exhibit the comments 'ELIGIBLE' and  'NOT ELIGIBLE' on the basis of the the 
data entered in a column in Open office Spreadsheet. Select the two methods from the list given 
below to complete the fields of 'Then_Value' and 'Otherwise_Value' in IF Function wizard?

a)   Type "ELIGIBLE  in  Then_Value box”
b)   Type " ELIGIBLE  in Otherwise_Value box”
c)  Type  "NOT ELIGIBLE  in Then_Value box”



d)  Type  " NOT ELIGIBLE in Otherwise_Value 

Ans: a)   Type  "ELIGIBLE  in  Then_Value box”
d) Type " NOT ELIGIBLE in Otherwise_Value

14. Select two Functions available in Open Office Spreadsheet to classify data?

  a)  IF
   b)  COUNT

  c)  SUM
  d)  LOOKUP

Answer :   a)  IF   d) LOOKUP

15. Which of the statements are true in the case of IF Function?

a. Help us to get the SUM
b. Allow us to print the specified area  in a document.
c. A technique in  Spreadsheet.
d. Help us to classify the data included in a table.

Answer
c. A technique  Spreadsheet.

d. Help us to classify the data included in a table.

16.Find out two methods from the following for preparing tables in Open Office Database.

a) Create Forms in Design View
b) Create Table in Design View
c) Use Wizard to Create Table
d) Use Wizard to Create Form

Answer: b) Create Table in Design View
c) Use Wizard  to Create  Table

17. Find out the two steps found in the process of 'Use Wizard to Create Form' in Open Office 
database.

a ) Field selection
b) Apply styles
c) Insert address block
d) Edit document

             
                Ans :  a ) Field selection 

   b) Apply styles

18.  Name the activities that can be done using New Print Composer  window in a map prepared 
using qgis software?    



           a. To view map select toggle Editing and click on the canvas.                          

b.  Add new label tool is used to give title to the map.  
c. using Add New Vector Legend tool it is possible to include legends in maps.  

d. Using 'Add North Line' tool it is possible to include  north line.  

Ans:-         b.   Add new label tool is used to give title to the map.  
                  c. using Add New Vector Legend tool it is possible to include legends in maps.  

...Which of the following are the  layer types in Qgis software?

a)Point
b)Line
c)Triangle
d)Square

Answer:a)Point 
  b)Line

19. Name the tools that can be used to mark the location of your home in wikimapia?

A. Search
B. Toggle Editing
C. Attributes

D. Add place

Ans: A. Search  
D. Add place

20. Find true statements from the list given below
a. In WikiMapia we can mark names of places ,roads,buildings and places  of worship. 
b. In wikimapia there are two methods to observe the maps, in satellite view and  in map 

view.

c. In wikimapia there is a facility called buffering , to find out the buildings affected by the 
widening roads. 
d. wikimapia is a qgis map.

Answer : a. In WikiMapia we can mark names of places ,roads,buildings and places  of worship. 
   b. In wikimapia there are two methods to observe maps, in satelite view and in map view.

21.Select the activities to show the details of the houses marked in Qgis Software 

a) After selecting the layer-House, select the houses by clicking  Identify Feature tool .
b) After selecting the layer-House, select the houses by clicking   Capture Point tool
c)  After  selecting  the  layer-House,  right  click  on  the  layer-House  and  select    Open 

attribute  table.



d)  After selecting the layer-House, select the layer-House and select  Toggle Editing  tool.

Answer :  a) After selecting the layer-House, select the houses by clicking  Identify Feature tool .
c) After selecting the layer-House, right click on the layer-House 

and select   Open attribute  table.

22. Which are the true statements regarding QGIS?

1. Analysis of information is possible  
2.Buffer(s) is possible  
3. Sky observation is possible.
4. No possibility for suitable additions

Ans  : -1. Analysis of information is possible  

2.Buffer(s) is possible     

23.Name the file formats to save a map prepared using QGIS Software.
1. pdf
2. avi
3. xcf

      4.  svg

Ans : -      1.  pdf
4. svg

24. 

Which of the following Python codes can give the whole numbers from 1 to 10 as its output?

a) for i in range(1,11):
          print i 

b)  for i in range(0,10,1):
1.                       print i 

c) i=0
    while(i<=10):
        print i 
        i=i+1

d) i=1
               while(i<=10):
                       print i 
                        i=i+1

Ans : a) for i in range(1,11):
                 print i 
         d) i=1
             while(i<=10):
                 print i 
                 i=i+1

25.   s=raw_input( Type Your Name and Press ENTER key ) “ ”
 n=len(s) 
 for i in range(n+1): 

        print s[:i]
                 



Some statements based on the above python program are given below. Examine them and 
select two suitable statements.

• The second line in the program is used to count the letters in the text.

• The second line in the program is for changing the letters in the text to capitals 

• This program doesn't run if the fourth line in the program is changed to print s[i:].

• This program runs even if the fourth line is changed to print s[i:].

Answer:
The second line in the program is used to count the letters in the text.
This program runs even if the fourth line is changed to print s[i:].

26. '+' is a symbol used in python programs.  Select activities for which this symbol is used ?

a) To find the sum of two numbers 

b) To join two strings

c) To separate codes

d) To print numbers

Ans:

a) To find the sum of two numbers 

b) To join two strings

27. Which  statements given below are true regarding"strings" in python program?

Options
a. strings are the data expressed as alphabets.   
b. strings cannot be added using'+' symbol.    
c. strings indicate numerals.

          d. Numbers given in quotations can also be strings

Answer:
 a. strings are the data expressed as alphabets
 d. Numbers given in quotations can also be strings

28.Arjun and Aswin prepared a program as given below, to add two numbers using python.

a=input( Enter First Number )“ ”
b=input( Enter Second Number )“ ”
c=a+b
print c

While running the saved program Arjun gave 5,3 as input while Aswin gave '5', '3'. Two of 
the statements on the output of the programme given below are correct. Select them? 



 a.) Arjun got 8 as output 
b.)Arjun got 53 as output        
c.) Aswin got 53 as output 
d.) Aswin got 8 as output 

Answer     :    a.) Arjun got 8 as output 
c.) Aswin got 53 as output 

29.Select the commands in python language from the list given below
1. for i in range(5):
2. raw_input
3. look up

           4.      Count if

  

 

Answer  :- 

1. for i in range(5):
2. raw_input

30.Given below are statements by Thomas and Remya on functions in python . select correct 
statements?

     1. They are independent sub programs.
     2. They are formulae included in a program.
     3.   They are programs that can be applied in other program.
     4.They are the instructions in a program related to mathematical operations.

Ans:1.They are independent sub programs.   
      3.They are programs that can be applied in  other programs.

31.A function for adding two numbers, is prepared as 'sum' and saved with the file name add.py. 

Rema has to include this function in her next program.  Select any two  suitable statements for the 

purpose from the list given below?

a) The command  'import add' should be given in the first line.
b) The command  'import sum' should be written in the first line 
c) The instruction print add.sum(45,56)  should be written in second line of program.      
d) print myfunction.sum(45,56)   should be written in second line of the program  .          

Answer:  a. The command  'import add' should be given in the first line.  
c. The instruction print add.sum(45,56)  should be written in the second line of the 

program.   



32.Identify the instructions to give 'data' as input in python program?

           a)  rawinput
           b)  raw_input

c)  import
d)  input

 Answer:
 b)  raw_input
d)  input

  

SECTION 3 .Make Shortnotes
(Select the most appropriate answer from each set to make short 
notes on the given topic.)

1.Inkscape
Step :1

A) A software that  creates raster images.
B) A software that  creates vector images.
C) A software that  creates 3D animations.
D) A software that  creates atlas. 

Answer :B) A software that creates vector images.

Step: 2
 : 

A) To create a fixed size canvas click 'Open -> New Canvas'. 
B) To create a fixed size canvas click 'File  -> Document Properties'.
C) To create a fixed size canvas click  'Layer ->  Add layer'.
D) To create a fixed size canvas click 'Create -> New Document'.

Answer: B. To create a fixed size canvas click File  -> Document Properties.

Step : 3

A) Use 'Move Tool' to arrange the size and position of the image. 
B) Use 'Select and Transform Object Tool' to arrange the size and position of the image.
C) Use 'Edit path by Node Tool' to arrange the size and position of the image. 
D) Use 'Zoom in or out Tool' to arrange the size and position of the image.

Answer:B.  Use 'Select and Transform Object Tool' to arrange the size and position of the image.

Step : 4

A) The default file format of this software is 'jpg'.
B) The default file format of this software is 'xcf'.



C) The default file format of this software is 'svg'.
      D)  The default file format of this software is 'gif'.

Answer: C. The default file format of this software is 'svg'.

2. Vector files
Step : 1

A) The position and colour of every dot in the canvas is recorded in a Vector File.

B) Only the position and colour of the end points of an image are recorded in a Vector File.

C) Only the colour of an image is recorded in a Vector File.

D) Only the size of an image is recorded in a Vector File.
Answer: B. Only the position and colour of the end points of an image are recorded in a Vector 
File.

Step : 2
A) Pictures are considered as a group of pixels.
B) Pictures are considered as group of colours.
C) Pictures are considered as a great single pixel.
D) Pictures are considered as geometrical forms as lines, circles and curves.

Answer:  D) Pictures are considered as geometrical forms as lines, circles and curves.

Step : 3

A) If the image expands, the new dots in the expanded canvas will be found out and recorded.
B) If the image expands, the old canvas will be erased.
C) If the image expands, the coloured dots will also be expanded.
D) If the image expands, the background colour will be changed.

Answer: A. If the image expands, the new dots in the expanded canvas will be found out and 
recorded.

Step : 4

A) The clarity decreases when the image is zoomed in.

B) The colour will change when the image is zoomed in.

C) The clarity sustains when the image is zoomed in.

D) The shape will alter when the image is zoomed in.
Answer: c) The clarity sustains when the image is zoomed in.

 

3. Raster files



Step  1

A) Clarity increases when a Raster image is zoomed in.

B)  There won't be any change in clarity when a Raster image is zoomed in.

C) Clarity decreases when a Raster image is zoomed in.

D) The Raster images always lack clarity..

Answer :B, Clarity decreases when a Raster image is zoomed in.

Step : 2

A)  Ink scape can only create the Raster images.

B)  Dia can only create  the Raster images.

C)  Open office draw can only creates the Raster images.

D)  GIMP can only create raster files.

Answer :D) GIMP can only create raster files..

Step : 3

A) When we draw a line in a raster canvas, the  pixels are coloured by the computer.

B) When we draw a line in a raster canvas, only the colour and the end dots are recorded by the 
computer.

C) When we draw a line in a raster canvas, it is recorded as geometrical shapes by the 
computer.

D) When we draw a line in a raster canvas, it is recorded as mathematical equations by the 
computer.

Answer :A,When we draw a line in a raster canvas, the  pixels are coloured by the computer.

Step 4

A) The svg files  are raster files.

B) The JPEG files  are  raster files. 

C) The odt files  are Raster files.

D) The ods files  are Raster files.

Answer :B, The JPEG files  are  raster files.



4.Mail Merge

Set 1

(a) This technique can be used for conditional classification of data in a database .
(b) Mail Merge is a technique used to mark a specific area around a selected 

geographical space. 
(c) With this technique one can make copies of a letter with different addresses from a 

database 
(d) Mail merge is a technique to collect the information of all the houses marked in 
a layer in the map.

Answer(c) With this technique one can make copies of a letter with different addresses from a 
database 
Set 2

(a) A template prepared  in Word Processor can be opened with Mail Merge 
Wizard in  Tools menu.  
(b) A template prepared  in Data Base can be opened with Mail Merge Wizard in  Tools 

menu. 
(c) A template prepared  in Word Processor can be opened with Mail Merge 
Wizard in  Table menu.  
(d) A template prepared  in Spreadsheet can be opened with Mail Merge 
Wizard in  Table menu.  

Answer(a)  A template prepared  in Word Processor can be opened with Mail Merge 
Wizard in  Tools menu

Set 3

(a)  Copy and paste  each data  to the space provided in the document.
(b)  Drag the data except the headings   to the space provided in the 
document.
(c) Drag the headings   to the space provided in the document.
(d)  Copy all the data in the database   to space provided  in the 
document.

Answer(c) Drag the headings   to the space provided in the document.
Set 4

(a) Select "Save merged document. 
(b) Save the document using 'Save as' in File menu.
(c) Save the document using 'Export as PDF' in File menu.
(d) Save the document using 'Save page as' in Edit menu.

Answer (a) Select "Save merged document”

5.LOOKUP



Set : 1

(a) Look up chart and the table can be prepared in the same sheet.
(b) Lookup Chart should be prepared in the home folder.
(c) Lookup Chart should be prepared in the table in Insert menu.
(d) Lookup Chart should be prepared in Open Office.org writer 

Answer (a) Look up chart and the table can be prepared in the same sheet.

Set.2 a) Save Lookup Chart  as a separate file.
b) Save  Lookup Chart  using Define range tool.
c)Save Lookup Chart  using Sort range.
d) Save Lookup Chart  with the extension .odt

c) Answer b) Save  Lookup Chart  using Define range tool.

Set.3
(a) The values of the search vector in the lookup Chart should be in ascending order.
(b) The values of the search vector in the lookup Chart should be in descending order.
(c ) The values of the search vector in the lookup Chart shouldn't be in any particular 

order. 
(d) The values of the search vector in the lookup Chart should be numerals.

Answer (a) The values of the search vector in the lookup Chart should be in ascending order.

Set.4

(a) LOOKUP Function can be applied using ' Function' in Tools menu.
(b) LOOKUP Function can be applied using ' Function' in Format menu..
(c) LOOKUP Function can be applied using ' Function' in Insert menu.
(d) LOOKUP Function can be applied using ' Function' in Data menu.

Answer  ( C) LOOKUP Function can be applied using ' Function' in Insert menu.

6.Database

Set-1
a) Database is a pool of information collected and consolidated for specific purposes.
b) Database is a pool of information collected in the form of alphabets.
c) Database is a pool of information collected with the help of OpenOffice.org Draw.
d)  Database is a pool of information collected with the help of OpenOffice.org Writer 

Answer:  a) Database is a pool of information collected and consolidated for specific purposes.

       Set-2

a) A method called Database Management System (DBMS) can be used for searching 
information in  database.

b) DBMS is a software used to create and handle data.



c) DBMS is pseudonym of OpenOffice.org Spreadsheet.
d) DBMS is an Office Management Software.

Answer:  b. DBMS is a software used to create and handle data.

     
 Set-3

a)   'Form' is a technique used for adding information in a table.
b)   'Report' is a technique used for adding information in a table.
c)   'OpenOffice.org Word Processor' is a technique used for adding information in a table.
d)   ' OpenOffice.org Presentation' is a technique used for adding information in a table.

Answer:  a)  'Form' is a technique used for adding information in a table.

      Set-4

a) 'Primary Key' helps to distinguish the 'Records' in a database.
b) 'Form' helps to distinguish the 'Records' in a database.
c) 'Primary Key' helps to distinguish the 'Tables' in a database.

      d) 'Primary Key' helps to distinguish the 'Forms' in a database.

 Answer:  a) 'Primary Key' helps to distinguish the 'Records' in a database.

7.DBMS(Database Management System)

SET 1
a) Secure handling of data is possible in this software.
b) This software is used only to tabulate the Data.
c) Data can be recorded as layers in this software.
d) Data can be prepared and formatted in this software.

Ans. a.  Secure handling of data is possible in this software.

SET 2
a) You have to prepare 'Form' in order to enter the data in  database. 
b) You have to prepare 'Template' in order to enter the data in  database.
c) You have to prepare a 'Table' and a 'Form' in order to enter the data in  database.
d) You have to prepare scan the data in order to enter the data in  database.

Ans. c.   You have to prepare a 'Table' and a 'Form' in order to enter the data in database.SET 3
SET 3

a) Data can't be added in all the fields of a database.
b) Any type of data can be added in any field of the database.
c) You can add  a specific kind of  data only in a specific field of the data base.
d) The first field in a database is exclusively made to enter numerals. 

Ans .c. You can add  a specific kind of  data only in a specific field of the data base.



SET 4

a) The original file format of a database in OpenOffice.org is 'odt'. 
b) The original file format of a database in OpenOffice.org is 'odb'.
c) The original file format of a database in OpenOffice.org is 'ods'.

                 d)    The original file format of a database in OpenOffice.org is 'odd'.

ANS: b)  The original file format of a database in OpenOffice.org is 'odb'.

8.Quantum Gis

Set 1

a.) To open Composer Window click New Print Composer in File Menu.
b.)To open Composer Window click New Project in File Menu.

           c) To open Composer window click Open Project in File Menu.
d.)To open Composer window click Project Properties in File Menu.

Ans:-a.) To open Composer Window click New Print Composer in File Menu.

Set 2

a.) Use Add Label tool in Composer Window to view the map.
           b) Use Add Image tool in Composer Window to view the map.

c.)Use Add Vector Legend tool in Composer Window to view the map.
d.)Use Add New Map tool in Composer Window to view the map.

Ans:-d.)Use Add New Map tool in Composer Window to view the map.

Set 3

a.) Use Add New Label tool  in Composer window to mark North Line.
b.)Use Add Image tool in Composer window to mark  North Line.
c.)Use Add Vector legend in Composer window to mark  North Line.
d.)Use Add New map tool in Composer window to mark  North Line.

Ans:-b.)Use Add Image tool in Composer window to mark  North Line.

Set 4

a.) Select File -> Export as Image in Composer window to save the map in a suitable 
Format.

b.)  Select  File -> Save as Template in Composer window to save the map in a suitable 
Format.

c.) Select Layout -> Save as Template in Composer window to save the map in a suitable 
Format.

d.)  Select Layout -> Export as Image in Composer window to save the map in a suitable 
Format.

Ans:-a.)  Select File -> Export as Image in Composer window to save the map in a suitable 



Format.

9. Adding information to the layer 'well '  in QGIS Software.

A) a) Hide the layer 'well' from the Overview panel.
b) Select the layer 'well' from the Overview panel.
c) Select the layer 'well' from the view menu.
d) Select the layer 'well' from the vector menu.

Answer :   b) Select the layer 'well' from the Overview panel.

B) a) Click the toggle editing button on the tool bar.
b) Click the node tool button on the tool bar.
c) Click the add ring button on the tool bar.
 d) Click the add part button on the tool bar.

Answer :    a) Click the toggle editing button on the tool bar.        

C) a) Click the nearby active polygon button.
b)Click the nearby active line button.
c)  Click the nearby active label button.
d)  Click the nearby active capture point button.

Answer :  d)  Click the nearby active capture point button. 

D) a) Give required information in the attribute window 
b) Give  required information in the vector window .
c) Give required information in the setting window 
d) Give required information in the raster window 

Answer : a) Give required information in the attribute window 

10.Properties of Wikimapia.
A.

a. Wikimapia is an example for QGIS map.
b. Wikimapia is an example for common map.
c. Wikimapia is an example for satellite map.

d.Wikimapia is an example for search engine.
Ans:- c. Wikimapia is an example for satellite map.              
B.

1. a. In wikimapia we can label names of places ,roads,institutions, places of worship etc.
b. In wikimapia there is a method to find out the buildings that will be affected by widening 

roads.
c. We can add information as layers in Wikimapia.
d. In wikimapia we cannot label names of places ,roads,institutions, places of worship etc.

Ans:- a. In wikimapia we can label names of places ,roads,institutions, places of worship etc.
C.



a. When buildings are given as layers in wikimapia, point is selected as layer type.
b. In wikimapia we can view map in Satellite and Map views
c. When public building is added as a layer in Wikimapia, polygon is used as layer type.

d. When well is added as layer in Wikimapia, point is used as layer type.
Ans:- b. In wikimapia we can view map in Satellite and Map views                                       
D.

a. In Wikimapia you can locate your school using search tool 
b. In wikimapia only towns can be located.
c. In wikimapia when boundaries are added as layers, point is selected as layer type.
d. In Wikimapia there is a method called filtering to locate the buildings that are affected by 

widening of roads. 

Answer :a. In Wikimapia you can locate your school using search tool

11.Python

I

• Data in strings are in the form of letters

• Data in strings are in the form of  numbers 

• Data in strings are both in the form of   numbers and letters

• Data in strings are  in the form of  pictures 

ans- Data in strings are in the form of letters

II

• The command 'input' is used to give string input to a variable. 

• 'for'  is a conditional command.

• 'if' is a repeating command.

• 'def' command is used to define function.

Answer:  'def' command is used to define function.

III

• In the command a=range(1,10,1), the start value of a is 10.

•  '+' symbol is used to find the sum of two strings in python.

• The start value (Ex: i=0)of the repeating variable should be given before the command 
'while'.

• IDLE is a program code generator. 

Answer :  The start value (Ex: i=0)of the repeating variable should be given before the command 
'while'.

IV 



• The command return is used to get back the answer to the main program while the 
function works.

• In a function for adding numbers the name of the function should be 'sum'.

• wxGlade can generate python codes only

• 'turtle' software is used to prepare python programs 

 Answer :   The command return is used to get back the answer to the main program while the 
function works.

12. A python  function  is  to  be prepared   to  calculate  the  average  of  two numbers.  
Choose the correct statement from each group for the purpose

Set I

1) def average(a,b)

2) def average(a,b):

3) average(a,b):

4) sum(a,b)

Ans :2) def average(a,b):

Set II

1) c=a * b

2) c=a/2

3) c=a + b

4) c=b/2

Ans :3) c=a + b

Set III

1)x=c * c

2)x=c+a

3) x= c+b

4) x=c/2

Ans :4) x=c/2

set IV

1)return x

2)return a



3)return b

4)return c

Ans :1)return x

13.Python Function

  
Set1 

(a) Python function is a repeated command used in programs.
(b) Python functions are independent sub programs.
(c) Function is a tutorial for learning language
(d) Function should be included in every python programs.

Answer (b) Python functions are independent sub programs.

Set 2
(a)  Function is prepared by using the command 'for'. 
(b) Function is prepared by using the command 'def'.   
(c) Function is prepared by using the command 'define'.    
(d) Function can be prepared without giving any command.

Answer (b)Function is prepared by using the command 'def'.

Set 3
(a) Functions can be used in other programs whenever is needed.
(b) Functions can't be used in other programs. 
(c) Only one function can be used in a  program.
(d) Functions are mandatory for all programs.

Answer (a) Functions can be used in other programs whenever is needed.

Set 4
(a)While the function at work, the command 'return' is used to get back the result  for the 
main program.
(b)While the function at work, the command 'return back' is used to get back the result  for 
the main program.
(c)While the function at work, the command 'rt' is used to get back the result  for the main 
program. 
(d)While the function at work, no command is used to get back the result  for the main 
program.

Answer(a)While the function at work, the command 'return' is used to get back the result 
for the main program.


